iOS JUnion SDK 集成指南

SDK集成-Vaas

最低支持系统: iOS 10.0。需要在Podfile中指定仓库和加入依赖如下:

source 'https://github.com/CocoaPods/Specs.git'
source 'https://github.com/aliyun/aliyun-specs.git'
source 'https://cdn.cocoapods.org/'
platform :ios, '10.0'
use_frameworks!
inhibit_all_warnings!
target '你的工程target' do
  pod 'KSAdSDK', '3.3.4'
  pod 'Bytedance-UnionAD', '~> 3.1.0.9'
  pod 'GDTMobSDK', '4.11.8'
  pod 'AlicloudHTTPDNS', '~> 1.19.2.6'
  pod 'JCore'
  pod 'Alamofire'
  pod 'AlamofireImage'
end
  1. OC项目接入:
    • 将JUnionSDK.framework和JUnionSDKResource.bundle文件拖入工程。
    • 在项目中新建一个swift文件,并跟随指引创建桥接文件(若已有桥接文件可跳过此步骤)。
  2. Swift项目接入:将JUnionSDK.framework和JUnionSDKResource.bundle文件拖入工程。
  3. 注意事项
    • 不支持bitcode
    • 不支持模拟器编译

更多API

其他 API 的使用方法请参考接口文档:iOS SDK API

技术支持

邮件联系:support@jiguang.cn


Copyright 2011-2020, jiguang.cn, All Rights Reserved.
粤ICP备12056275号-13 深圳市和讯华谷信息技术有限公司

Documentation built with MkDocs.